User avatar
Murloc992
Posts: 116
Joined: Feb 28, 2017 5:19 pm
Answers: 3
Location: Lithuania
Contact: Send private message

MK2S -> MK2.5 way worse printing quality and weird flow

Aug 03, 2018 5:37 pm

Hello,

I have owned my prusa for more than a year now and finally got it working with the MK2.5 upgrade.

Everything calibrates just fine, but I am having some terrible printing quality now and weird flow..

I am using firmware 3.3.1, Slic3r 1.41 (no matter the version things stay the same).

My calibration is perpendicular with 0.02 degree skew as indicated by the Support menu.

Here are some examples of what I am having now:
Image
Image
Image

This is what I had before the upgrade (right) compared with what I have now (left):
Image

The thing is, I think the flow is terrible somehow..

I am using the default steps now after a factory reset (133). With that I feel like I am getting huge over-extrusion but even when I go to 0.9 flow I see over extrusion on perimeters and gaps on top layers..

When I calibrate the extruder, my steps become 143, but then flow must become less than 0.85 (more like 0.79) to look "good" (quality and gaps remain the same as uncalibrated).

Filament is PETG from a brand which I have been using for a WHILE.

Also seems like stringing has started to occur exactly after the upgrade.

Tolerances are way off too.. Before I could get to 0.1mm tolerances or less just by doing extruder steps calibration..

Anybody had this issue and know where to start?

Best Answer by Murloc992 » Dec 08, 2018 9:15 pm
I narrowed it down to Slic3r too. Two direct extruder printers. Same E3DV6 hotends, same Slic3r settings, same outcomes. Only difference being one has steps at 144(prusa) and another has 190(anycubic). Both must have flow rate at 0.9, both print identical prints. I will probably try to play around with other software instead of facing shenanigans from Slic3r.

GO TO FULL POST ➙

User avatar
Murloc992
Posts: 116
Joined: Feb 28, 2017 5:19 pm
Answers: 3
Location: Lithuania
Contact: Send private message

Re: MK2S -> MK2.5 way worse printing quality and weird flow

Nov 21, 2018 7:37 am

Haven't completed a single print since the time I originally posted. Why did I touch my fully working MK2S and why this hasn't been addressed/fixed(in the firmware/extruder design) is beyond me..

User avatar
Murloc992
Posts: 116
Joined: Feb 28, 2017 5:19 pm
Answers: 3
Location: Lithuania
Contact: Send private message

Re: MK2S -> MK2.5 way worse printing quality and weird flow

Dec 02, 2018 11:45 am

I got some free time to "play around".

Redone extruder calibration several times.

Using firmware 3.5.0 instead of 3.4.x(don't remember at the moment) in hopes of salvation, but...

Instead of default steps 133 I had to set steps to 149.6 according to 120mm extrusion calibration on matts hub so exactly 100mm go through.

Image

This is major overextrusion. Single wall cube is exactly at 0.45mm walls.

Then I just reverted back to default and did same prints:

Image

Still over extruding. Single wall cube is exactly at 0.4mm walls.

What is wrong with my MK2.5? Swear it was a wrong idea to upgrade it from MK2S, because over this time even a chinese printer I have is faring better..

Help, please!

User avatar
Murloc992
Posts: 116
Joined: Feb 28, 2017 5:19 pm
Answers: 3
Location: Lithuania
Contact: Send private message

Re: MK2S -> MK2.5 way worse printing quality and weird flow

Dec 02, 2018 12:54 pm

Switched the nozzle to no avail.

Image

I think I saw this extrusion pattern like forever since upgrading to 2.5.

User avatar
Murloc992
Posts: 116
Joined: Feb 28, 2017 5:19 pm
Answers: 3
Location: Lithuania
Contact: Send private message

Re: MK2S -> MK2.5 way worse printing quality and weird flow

Dec 03, 2018 8:52 am

Further playing around and talking to myself..

I have calibrated the extruder using Prusa PLA.

Using 215'C and extruding 100mm cleanly set my steps to 144.

The models print quite nicer and top layers look way better, but.. Still over extruding and tolerances are off the charts (nothing fits)..

Image

Two different models compared. Orange is a bit better now.

Image

Top layer is still a mess and nothing fits.


Started playing around with flow rates.

0.95, 0.9 didn't do anything significant.

0.85 on the other hand is tolerable and I could make the 'calibration S plugs' fit.

Thing is, now dimensions are off, as I am underextruding.

Theoretically with flow rate adjustment I now have my steps at 122.4. Default is 133. Calibrated is 144.

Really would love some clarification on what is going on with this random extrusion shenanigans.

pekka.p
Posts: 13
Joined: Oct 26, 2016 7:53 pm
Answers: 1
Contact: Send private message

Re: MK2S -> MK2.5 way worse printing quality and weird flow

Dec 05, 2018 9:58 am

Are those sliced with Slic3r PE? I've noticed that gcode sliced with it is more 'stuffed' than gcode from KISSlicer or Simplify3D. I use KISS almost exclusively nowadays since it seems to produce most accurate parts.
After upgrading my MK2 with Titan extruder this was even more pronounced to the point the some models sliced with Slic3r PE were unusable so I'm wondering if Slic3r PE is simply tuned to over-extrude some...

User avatar
Murloc992
Posts: 116
Joined: Feb 28, 2017 5:19 pm
Answers: 3
Location: Lithuania
Contact: Send private message

Re: MK2S -> MK2.5 way worse printing quality and weird flow

Dec 08, 2018 9:15 pm

I narrowed it down to Slic3r too. Two direct extruder printers. Same E3DV6 hotends, same Slic3r settings, same outcomes. Only difference being one has steps at 144(prusa) and another has 190(anycubic). Both must have flow rate at 0.9, both print identical prints. I will probably try to play around with other software instead of facing shenanigans from Slic3r.

Return to “Assembly and first prints troubleshooting”

Who is online

Users browsing this forum: No registered users and 1 guest