samuel.b
Posts: 5
Joined: Feb 05, 2017 10:09 pm
Contact: Send private message

Thermal Runaway on i3 mk2 with no working solution from other posts

Feb 12, 2019 3:37 am

Hi all -

I'm running into a relatively consistent thermal runaway on my i3 mk2.

It's occuring at various times into prints, ranging from a few hours to less than 2 minutes. This is with several different prints, including printing the same object repeatedly (I have a box of partially printed airplanes) but with different settings each time. That's included varrying the fan speeds from 0-100%, changing print speed, layer settings, even just infill. I tried to be fairly thorough to try and find the issue.

For troubleshooting I've checked all wire connections and found them to be intact. Adjusted print settings mentioned above. The printer is in the same place as it's always been, a mid sized room in a heated apartment. I've even tried asking it nicely.

Best I can tell I've done all the recommended steps in the forums for these issues. It's starting to feel like it just can't keep the temp up for extended periods of time anymore, but I wouldn't expect the hotend to be the piece to die on me, or in this fashion.

Any and all recommendations are appreciated.

RetireeJay
Posts: 179
Joined: Feb 13, 2018 10:47 pm
Answers: 3
Contact: Send private message

Re: Thermal Runaway on i3 mk2 with no working solution from other posts

Feb 12, 2019 3:58 am

So just to be clear, I assume that the printer is stopping with an error message of "Thermal Runaway"?

A likely cause of quasi-random thermal runaway errors is a fatigued lead on the thermistor cable. Repeated bending back and forth at a point will eventually break the copper wires inside the insulating jacket. Once broken, they may still be in contact a lot of the time but lose contact occasionally depending on the motion of the extruder. If you monitor the temperature (even at room temperature) while exercising the wire, you may find certain positions where the indicated temperature drops to zero. If so, then it's definitely the wire.

User avatar
nikolai.r
Posts: 934
Joined: Nov 09, 2016 8:32 am
Answers: 4
Location: USA - California
Contact: Send private message

Re: Thermal Runaway on i3 mk2 with no working solution from other posts

Feb 12, 2019 5:45 am

On MK2 machines any thermal runaway is over 90% broken thermistor cable. Check if it's a bed thermal runaway or extruder. If it's extruder, I would suggest to replace the thermistor. They are pretty inexpensive. If it's bed, then just replace the cables.
For extruder case it might also be the temperature sensor/cable.
Anyway my bet goes on broken cables.

samuel.b
Posts: 5
Joined: Feb 05, 2017 10:09 pm
Contact: Send private message

Re: Thermal Runaway on i3 mk2 with no working solution from other posts

Feb 12, 2019 2:45 pm

Alright, I'll take a look at replacing the thermistor. Looks like that's a fairly straight forward fix.

I've actually had issues where the wires for the bed just wore out and got intermittent connection issues. Fixed that a while back with some new wires and better reinforcement.

One question for the thermistor: What would I expect to see for temp behavior if it was failing? Would there be sharp drops in temp (i.e. from 200 to 0 in a second) or would a gradual decent (what you'd expect to see if you just finished a print) make sense?

I ask since I've sat by the printer and watched the temperature, and before it fails the temp will just gradually drop. The behavior is what I'd expect if it just turned off the hotend. I would imagine if it was the thermistor failing then the temp would be more erratic.

Anywho, I'll check the termistor and report back ASAP.

RetireeJay
Posts: 179
Joined: Feb 13, 2018 10:47 pm
Answers: 3
Contact: Send private message

Re: Thermal Runaway on i3 mk2 with no working solution from other posts

Feb 12, 2019 3:14 pm

One question for the thermistor: What would I expect to see for temp behavior if it was failing? Would there be sharp drops in temp (i.e. from 200 to 0 in a second) or would a gradual decent (what you'd expect to see if you just finished a print) make sense?
Yes, a frayed wire that's making intermittent contact will result in sudden drops in the indicated temperature, usually all the way to zero in a millisecond, although intermediate temperatures are possible. BTW, if a short circuit between the wires going to the thermistor should ever occur (not a common situation) the indicated temperature would instantly rise to the maximum (somewhere over 300C).

Any erratic jumps in temperature that don't make physical sense based on the thermal mass of the hot end (or bed) are an indication of problems with the wiring (or possibly the thermistor itself is not in good physical contact with the thing it's measuring). If you pulled a working thermistor with good wiring out of the hot end or off the bed, the indicated temperature would change in a few seconds, but not instantaneously.

User avatar
nikolai.r
Posts: 934
Joined: Nov 09, 2016 8:32 am
Answers: 4
Location: USA - California
Contact: Send private message

Re: Thermal Runaway on i3 mk2 with no working solution from other posts

Feb 12, 2019 5:39 pm

samuel.b wrote:
Feb 12, 2019 2:45 pm
One question for the thermistor: What would I expect to see for temp behavior if it was failing? Would there be sharp drops in temp (i.e. from 200 to 0 in a second) or would a gradual decent (what you'd expect to see if you just finished a print) make sense?

I ask since I've sat by the printer and watched the temperature, and before it fails the temp will just gradually drop. The behavior is what I'd expect if it just turned off the hotend. I would imagine if it was the thermistor failing then the temp would be more erratic.
You're right. Thermistor failure will result in drastic value changes. Steady change points toward the heater element. This need to be replaced as-well

samuel.b
Posts: 5
Joined: Feb 05, 2017 10:09 pm
Contact: Send private message

Re: Thermal Runaway on i3 mk2 with no working solution from other posts

Feb 12, 2019 10:55 pm

Again, appreciate the responses.

Both parts were fairly inexpensive so I ordered a new thermistor and heater element. With luck it'll just be one of those two!

Will update when I have results, will depend on shipping times.

Return to “Hardware, firmware and software help”

Who is online

Users browsing this forum: No registered users and 2 guests