sasha.s
Posts: 7
Joined: Nov 08, 2016 4:50 pm
Contact: Send private message

Selftest error Heater/Thermistor Not connected

Jun 18, 2017 10:32 pm

I'm putting this here even though I've already resolved it to make the issue easier for others to spot. With the 3.0.11 firmware The selftest fails with a "Heater/Thermistor Not connected" error even though they appear to be working fine otherwise. The cause appears to be an overly strict test duration and thresholds, as described here: https://github.com/prusa3d/Prusa-Firmware/issues/116.

joshua.q4
Posts: 1
Joined: Dec 26, 2018 2:09 pm
Contact: Send private message

Re: Selftest error Heater/Thermistor Not connected

Jan 13, 2019 1:51 am

Hi,
I am posting this here as it seems to be the best place to. I experienced a similar fault on my kit printer shipped on Jan 7th 2019. I could not pass the self test and it would give me the "Heater/Thermistor Not connected" during the self test. I updated to the latest firmware 3.5.1 and after looking over the wiring and checking for continuity still did not work. I decided to do a pre warm up on the heater and bed and both worked and regulated their temperatures. I then went to the calibration wizard and ran the calibration again and it waited for the bed and nozzle to cool down. The self test then worked and I was able to complete calibration. Now let me explain. My shop is in the attached and somewhat heated garage and ambient temperature is around 55 to 60 degrees right now during the winter. Like the post above indicates the timeout threshold is too short if the ambient temperature is too low around the printer. Printer has been running fine ever since. So if you come across this problem perhaps it is too cold where you are storing the printer. Good Luck printing!

aaron.d15
Posts: 2
Joined: Jan 02, 2019 3:17 am
Contact: Send private message

Re: Selftest error Heater/Thermistor Not connected

Jan 16, 2019 8:07 am

Thank you thank you. Exactly same set of circumstances for me. Wish I had figured it out before double and triple checking everything else.
joshua.q4 wrote:
Jan 13, 2019 1:51 am
Hi,
I am posting this here as it seems to be the best place to. I experienced a similar fault on my kit printer shipped on Jan 7th 2019. I could not pass the self test and it would give me the "Heater/Thermistor Not connected" during the self test. I updated to the latest firmware 3.5.1 and after looking over the wiring and checking for continuity still did not work. I decided to do a pre warm up on the heater and bed and both worked and regulated their temperatures. I then went to the calibration wizard and ran the calibration again and it waited for the bed and nozzle to cool down. The self test then worked and I was able to complete calibration. Now let me explain. My shop is in the attached and somewhat heated garage and ambient temperature is around 55 to 60 degrees right now during the winter. Like the post above indicates the timeout threshold is too short if the ambient temperature is too low around the printer. Printer has been running fine ever since. So if you come across this problem perhaps it is too cold where you are storing the printer. Good Luck printing!

diego.p11
Posts: 5
Joined: Jul 13, 2018 8:15 am
Contact: Send private message

Re: Selftest error Heater/Thermistor Not connected

Feb 11, 2019 9:20 am

Thanks. That has helped me.

Return to “Others (Archive)”

Who is online

Users browsing this forum: No registered users and 13 guests